لینوکس و من

لینوکس و من

لینوکس و من

حاصل تجربیات ما از سر و کله زدن ها با لینوکس

بایگانی

جلوگیری از آپدیت شدن libreoffice

در پست های قبل نوشته بودم که چطوری از آپدیت شدن خودکار یک بسته جلوگیری کنیم. LibreOffice از اون برنامه هاییه که حجم بالایی داره. و آپدیت شدنش به نسخه های ریز فرعی به نظر من زیاد لازم نیست. مگه اینکه بخواد به یک نسخه ی اصلی آپدیت بشه. حالا طبق همون پست، این دستورات رو که وارد کردم برای شما هم میذارم. و هم برای خودم میمونه اگه بعدا لازم شد استفاده کنم. یکی یکی این دستورات رو در ترمینال اجرا کنید. اما:۱- هیچ برنامه ای که به مخازن دسترسی داره باز نباشه. مثلا synaptic۲- در ترمینال باید با حالت root وارد شده باشید. بنابراین اول دستور su رو اجرا کنید.این هم دستورات:echo "libreoffice-style-tango hold" | dpkg --set-selectionecho "libreoffice-style-galaxy hold" | dpkg --set-selectionecho "libreofficestyle-galaxy hold" | dpkg --set-selectionsecho "libreoffice-report-builder-bin hold" | dpkg --set-selectionsecho "libreoffice-java-common hold" | dpkg --set-selectionsecho "libreoffice-help-en-us hold" | dpkg --set-selectionsecho "libreoffice-filter-mobiledev hold" | dpkg --set-selectionsecho "libreoffice-emailmerge hold" | dpkg --set-selectionsecho "libreoffice-common hold" | dpkg --set-selectionsecho "libreoffice-core hold" | dpkg --set-selectionsecho "libreoffice-base hold" | dpkg --set-selectionsاین دستورات کافی هستند تا مشتقات دیگه هم آپدیت نشن. توجه کنید که امکان آپدیت همچنان وجود داره، یعنی هر وقت که خودتون بخواید میتونید از توی پکیج منیجر تیک اپدیت شدن این بسته ها رو بزنید. این کار ما فقط جلوی آپدیت شدن اتوماتیک این بسته ها رو میگیره.اگه شما هم بسته ی دیگه ای از LibreOffice رو دیدید که با وجود دستورهای بالا لازمه این اتفاق براش بیفته در کامنت ها بنویسید. ممنون میشم.
دسته:

ترفند

کلیدواژه:

libreoffice

دبیان

نظرات  (۲)

  • فاروق کریمی زاده
  • یا اینجوری:
    echo libreoffice{-core,-base,-common,...} hold
    البته ممکنه یک حلقه ی for هم نیاز باشه
    سلام
    ممنون از انتشار مطلب زیر
    برای من پیغام خطا را نشون میده
    چرا نمیشه ینجا کپی پیست کرد !!!
    پاسخ:
    متاسفانه این ضعف شدید میهن بلاگه! بهشون هم گفتم، هیچ اهمیتی ندادن. این مطلب خیلی قدیمیه، اسم بسته ها حتما تا الان باید عوض شده باشه دیگه. احتمالا شما دچار همین مشکل شدید.